Mail.RuПочтаМой МирОдноклассникиИгрыЗнакомстваНовостиПоискВсе проекты
13 июля 2013, 09:21, Форум, Досуг, Обо всём на свете

Вопрос программистам и знатокам Exel

Задача: есть информация в столбе А - вт 345
                                                                         ва 456
                                                                         дл 987

в столбце В - вт 345
                         щш 987
                         вд 098
Как прописать формулу, чтобы в столбец С вывели совпадение вт -345? То есть нашли все возможные совпадения из столбцов А и В? 















 
Тема закрытаТема скрыта
Пожаловаться
Анна, 2 ребенка
если А=В, то А, иначе ничего - формулы искать лень ;)
Пожаловаться
Lana
Вот формула  и нужны.... не получается найти самой (((
Там столбцы - в них надо сравнить значения в ячейках.
Пожаловаться
Анна, 2 ребенка
=ЕСЛИ(А1=В1; А1; ) - вот так вроде
Пожаловаться
Lana
неа.... а1 может быть равно в5 - эти данные и надо вытащить - сопвпадения
Пожаловаться
Анна, 2 ребенка
а в каком виде тогда вывод? вы напишите полностью задачу, или что требуется 
Пожаловаться
Lana
вывод в ячейке С - можно =, можно правда-истина- ложь...или лучше значение ва 345 вто 567. что именно совпадает
Пожаловаться
Lana
Есть база данных, фильтры там некорректные, мне надо узнать компания город Ы с объемом продаже больше 100.
Могу там вытащить компании (там вседанные по России) с доходом больше ста. И могу взять все компании из города Ы. Надо совместить эти данные и найти компанию из города Ы с объемом больше 100. 
Как-то так. 
Пожаловаться
Анна, 2 ребенка
что-то я не очень могу соотнести это с вашим вопросом...

345      345                                 345
457     45                                  
98        678                                 98
65        98
798      479

вам что-то типа этого нужно? сравниваем А1 со всеми В и, если находим совпадение, выводим в ячейку С1 значение, равное А1 и тд
Пожаловаться
Lana
Именно это и надо! 
Пожаловаться
Анна, 2 ребенка
=ЕСЛИ(А1=ВПР(А1; В1:В1000; 2; 0); А1; 0)

попробуйте так, но я не очень уверена в параметрах впр, так как у меня нет excel.
Пожаловаться
Lana
НЕ ВЫХОДИТ((
Пожаловаться
Анна, 2 ребенка
дайте скрин экселя посмотреть
Пожаловаться
Lana
Пожаловаться
Анна, 2 ребенка
не особо видно
=ЕСЛИ(А1=ВПР(А1; В1:В1000; 2; 0); А1; 0)

в этой формуле я считала, что мы сравниваем значения столбцов А и В. Соответственно вместо А1 ставите первую ячейку первого сравниваемого столбца, вместо В1:В1000 - весь массив второго столбца, 2 - это номер второго столбца (у вас вроде 3 надо поставить). 
Пожаловаться
Lana
НЕ ГРУЗИТ чтото скрин новый. формулу ввела =ЕСЛИ(A3=C:C;A3; - выход по форумуле =ЕСЛИ(A3=C:C;A3;"N0";)
Пожаловаться
Lana
Но так получается на каждую ячейку 750 раз вручную формуды вводить
Пожаловаться
Lana
Пожаловаться
Батончик нарезной, 1 ребенок
число с массивом у вас не получится сравнить, к сожалению
Пожаловаться
Анна, 2 ребенка
прочерк не пишите, оставьте пустое место - так даже проще, если формула позволяет
Пожаловаться
Lana
Я вчера 3 часа мучилась, не получается так - никак у меня...((((
Там массив информации в А - 3 тыщи, в В - 750....вручную не найдешь, а в формулах запуталась ((((
Пожаловаться
Елена Гученко, 6 детей
Вот в такие моменты я особенно чётко могу провести аналогию между собой и шимпанзе....
Пожаловаться
Lana
:D:D:D сижу дальще мучаюсь, попробовала формулой=ЕЛОГИЧ(A:A=C:C - результат где ИСТИНА, там истина значение из столбца А данные, или из С ? 
И вообще, верная ли формула :D:D:D:D
Пожаловаться
Елена Гученко, 6 детей
Если вы сейчас подойдёте к шкафу и зададите этот вопрос, то вероятность услышать правильный ответ будет гораздо выше чем от меня)))
Пожаловаться
Дважды МАМА, 2 ребенка
Слава Богу, я не одна такая)))))
Пожаловаться
худеющая
принимайте и меня в стаю:D
Пожаловаться
Поделиться темой:
Подпишитесь на нас